• Welcome to Peterborough Linux User Group (Canada) Forum.

Computer BIOS locked down

Started by ssfc72, November 15, 2016, 05:28:43 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I was helping a person, here in Lindsay, with his desktop computer.  His computer started to give an DOS error message about a .dll file being missing and it would not boot into Win7.

It seemed like a probably easy fix, to me, so I said I would have a go at trying to fix it. It wound up taking me a number of hours to resolve.

I thought I would just do a Safe Boot or boot from a Win7 recovery disk and do a system restore or repair.  No such luck!

I got the system restore menu up on the computer, to access the restore partition recovery files, on the computer but it then wanted the password!!!
The guy didn't know what the password was.  His computer was set to boot into Win7 without him having to enter a password, so he didn't know the System password.

No problem.  I would just boot into Win7 recovery from the guys recovery disk, that he had made?    No recovery disk was made.

No problem. I would just use a Win7 recovery disk, that I had from my computer.
Well guess what!  The computer would not boot from the CDROM or the USB port!  :-(

I go into the BIOS ( a computer, Core 2 Duo HP) and sure enough the BIOS was set to boot from the hard drive first, then the cdrom, then the usb.
No problem, I would just change that boot order in the bios!   No way!!! :-(   The BIOS was password protected. :-(

This fellow got this computer from some computer quy that repairs computers, who no longer was around.  I think it must have been a business computer, at one time.
The specs on the internet, say it was originally a Vista OS box and the hard drive was smaller than what was currently in the box.
I don't know why the computer quy would password protect the BIOS?

Anyway, I tried to reset the bios back to Default settings, from the bios menu and that didn't seem to work.

Then I went looking for a bios reset jumper on the motherboard and didn't see one, near the CMOS button cell battery.
So I popped out the battery for a few seconds and then re-installed.

Now at this point, I seemed to have got the bios, boot order changed, after I did another,  bios Default settings, selection from the bios menu.

The BIOS however still seemed to be looked down with a password, because the bios clock time/date had got changed to the year 2080.
There was no way I could get the time/date to change back to the correct year, :-(

I went back to the motherboard and looked again for a BIOS jumper and sure enough I found 3 jumpers, a little further away from the bios battery.
I chose the one jumper that was labeled on the motherboard with what looked like it might be the bios jumper.
This jumper did only had 2 pins on the motherboard, instead of 3 pins, which is what I am used to seeing.
The internet instructions said to remove the jumper from the pins, on the motherboard (for a 2 pin jumper), reboot the computer, then shut down the computer and put the jumper back on.

I just booted up the computer and went into the BIOS and tried to change the date and it worked fine!!  I then shut down the computer and replaced the jumper onto the 2 pins.

So, now I thought I was good to go and that I would just boot from a recovery cdrom and do a restore of Win7  Wrong!!!
The recovery cdrom booted up just fine but the recovery failed!!

So now I pull out my Puppy Linux usb bootable flash drive and boot into Puppy.  I find the folders/files on the hard drive and save the guys data to a flash drive.

At this point I am thinking of doing a fresh install of Win7.  So I pull out my Clonezilla backup imaging usb flash drive and proceed to image off the existing hard drive, just in case I might want to restore the drive.  Wrong!!!
Clonezilla comes back after starting the imaging routine and reports that the drive has bad sectors!!!

So now I know why the .dll file went missing.  The hard drive is toast!!

We are now looking at a new internal Sata hard drive from Amazon.ca for about $60.


Mint 20.3 on a Dell 14" Inspiron notebook, HP Pavilion X360, 11" k120ca notebook (Linux Lubuntu), Dell 13" XPS notebook computer (MXLinux)
Cellphone Samsung A50, Koodo pre paid service


Sounds like a grand ole' time for you, Bill! Thanks for sharing your experience. It's a good example of a logical and thorough troubleshooting.
* Zorin OS 17.1 Core and Windows 11 Pro on a Dell Precision 3630 Tower with an
i5-8600 3.1 GHz 6-core processor, dual 22" displays, 16 GB of RAM, 512 GB Nvme and a Geforce 1060 6 GB card
* Motorola Edge (2022) phone with Android 13


Wow, what a story. Way to go, Bill! I think that the time you spent on the problem is worth an order of magnitude more than the $60 HD replacement. But challenges like this are really fun, if you can solve them.  :)
Ubuntu 23.10 on 2019 5k iMac
Ubuntu 22.04 on Dell XPS 13


Yes, a seemingly simple problem turned out to be much more complex and it then became a challenge for me to be able to solve it and also to learn something.  It was fun to do!
Mint 20.3 on a Dell 14" Inspiron notebook, HP Pavilion X360, 11" k120ca notebook (Linux Lubuntu), Dell 13" XPS notebook computer (MXLinux)
Cellphone Samsung A50, Koodo pre paid service