Author Topic: VMWare Workstation Player issue - Guest does not show after install  (Read 1083 times)

0 Members and 1 Guest are viewing this topic.

Offline ssfc72

  • Member
  • Master
  • *
  • Posts: 1819
I remember having run into this problem before but I can't find the Forum message that I posted, from a number of years ago.

I am running Mint 19x as the Host and I go to create a new Guest.  I go through the install of a Linux Distro and it installs and boots up the Guest. When I shut down the Guest Distro and start the VMWare player again, the installed Guest does not show up under the Home folder of the VMWare player.
 In  the VMWare player I can locate the folder that the Guest distro is located but when I try to run the .vmx file (?), nothing happens.

What I am doing wrong? I have tried installing 2 different Linux Distros and the same issue occurs with both.
I am really p offed, that I am having this same problem with a Virtual Machine program, that I had a number of years ago! :-(

Edit - I have found that from the Host distro, I can navigate to the VMWare folder and the Guest distro folder and click on the .vmx file and get the Guest to boot up.  The Guest still does not show up from the VMWare player program under the Home folder that is found in the main Player window.
« Last Edit: January 29, 2020, 03:29:03 am by ssfc72 »
Mint 19.1 on a Dell 14" Inspiron notebook, HP Pavilion X360, 11" k120ca notebook (Linux Lubuntu), Dell 13" XPS notebook computer (MX Linux)
Cellphone Samsung A50, PCMobile pay as you go

Offline buster

  • Member
  • Master
  • *
  • Posts: 1199
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #1 on: January 29, 2020, 09:24:40 am »
Hi Bill,
I've seen this before when I've moved guest distros between computers, and when stashing guests on hd's with more space, and maybe when cloning.

I remember going thru something like player>file>open and I think maybe right clicking on the file? Whatever, it asked me to choose something (?) and I chose the default which always works - 'I moved it'.

From then on it worked perfectly. I do remember trying it get it started by clicking on the .vmx file and going nowhere.
The Ironic Big Bust Theory: The likelihood of an advanced species imploding in apocalyptic stupidity. (Intergalactic Survey of Disappearing Civilizations: Chapter 4))

Offline ssfc72

  • Member
  • Master
  • *
  • Posts: 1819
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #2 on: January 29, 2020, 04:13:38 pm »
This issue dates back to Dec 2017 and seems to be an ongoing, unfixed bug.

https://communities.vmware.com/thread/578176?start=15&tstart=0

Answer #9 seems to be the fix for all the Mint Distros, including Mint 19x.    In Mint, type in the search field, "privacy" without the quotes,in the Menu.  Click on the Privacy setting program and turn on "remember recently accessed  files" and "never forget old files". Problem fixed.
Mint 19.1 on a Dell 14" Inspiron notebook, HP Pavilion X360, 11" k120ca notebook (Linux Lubuntu), Dell 13" XPS notebook computer (MX Linux)
Cellphone Samsung A50, PCMobile pay as you go

Offline buster

  • Member
  • Master
  • *
  • Posts: 1199
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #3 on: January 29, 2020, 05:36:50 pm »
Hmmm. Never really noticed anything very unusual with my Mint.
The Ironic Big Bust Theory: The likelihood of an advanced species imploding in apocalyptic stupidity. (Intergalactic Survey of Disappearing Civilizations: Chapter 4))

Offline ssfc72

  • Member
  • Master
  • *
  • Posts: 1819
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #4 on: January 29, 2020, 05:56:01 pm »
Harry, are you running VMWare player with Mint as a Host?  I thought you were running VMWare with Win 10 as the Host. Maybe that is why you have not seen this issue?
Mint 19.1 on a Dell 14" Inspiron notebook, HP Pavilion X360, 11" k120ca notebook (Linux Lubuntu), Dell 13" XPS notebook computer (MX Linux)
Cellphone Samsung A50, PCMobile pay as you go

Offline buster

  • Member
  • Master
  • *
  • Posts: 1199
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #5 on: January 29, 2020, 06:55:34 pm »
I do both. I'm 'ambidextrous'.  :) Both work, but Win10 host seems to be easier than my Mint.
The Ironic Big Bust Theory: The likelihood of an advanced species imploding in apocalyptic stupidity. (Intergalactic Survey of Disappearing Civilizations: Chapter 4))

Offline ssfc72

  • Member
  • Master
  • *
  • Posts: 1819
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #6 on: January 30, 2020, 03:09:57 am »
Thanks for your help, Harry.
Mint 19.1 on a Dell 14" Inspiron notebook, HP Pavilion X360, 11" k120ca notebook (Linux Lubuntu), Dell 13" XPS notebook computer (MX Linux)
Cellphone Samsung A50, PCMobile pay as you go

Offline Jason

  • Administrator
  • Master
  • *****
  • Posts: 3737
  • Humanist. Skeptic. Husband.
Re: VMWare Workstation Player issue - Guest does not show after install
« Reply #7 on: January 30, 2020, 06:53:58 am »
Hey Bill, long time viewer, first time poster (in this topic). I've had this issue as well although it was in my present Kubuntu system. I had removed VMware because of this bug because I didn't know about the workaround Buster suggested. I stopped using it. Came back to using it again recently and it works as it should now. Thanks for finding the bug listing and the solution in case it happens again.
"With all its sham, drudgery, and broken dreams, it is still a beautiful world." - Max Ehrmann, Desiderata