Peterborough LUG (Canada) Forum

Linux & Android => Support => Topic started by: fox on January 09, 2021, 08:17:05 am

Title: Slowwww web browsing on RPi 4
Post by: fox on January 09, 2021, 08:17:05 am
My RPi 4 kit arrived yesterday and after assembling it, I put the Noobs SD card in to try it out. The Pi 4 was very responsive in comparison to the 3B in terms of start-up time, opening folders and moving windows. It seemed about the same or maybe a bit faster when starting up programs like LibreOffice writer. But it was glacial when it came to browsing. I was using the installed Chromium browser. It took what seemed to be a long time to start up, but once it started, anything else I did in it was much worse. Putting text in a window was painfully slow - there was a big delay in the text showing up in a search box after I typed it. (And I'm using a USB keyboard, not a Bluetooth.) Trying to close windows was glacially slow as well. What gives? Has anyone seen this on their Pi? Is it a problem with Chromium? I had read that you get this type of problem with Firefox in Raspberry Pi OS, not Chromium. Could it be stuff it is doing in the background? Could it be the Sandisk SD card it came with?

Ultimately I won't be using that card or Noobs; I'll go to Berryboot and install a few distros to try them, and then I want to try making a server with NextCloud instead of OpenMediaVault using Jason's presentation tutorial. I will also be using an SSD to boot and run the distro; I think you still have to start the initiation from the SD card first but then it switches over to the SSD if you set it up that way. I'm sure that this will speed things up considerably, but meanwhile I would like to solve the Chromium problem.
Title: Re: Slowwww web browsing on RPi 4
Post by: ssfc72 on January 09, 2021, 09:07:06 am
Sounds to me like some hardware is not working correctly.  I would suspect the SD card.
I am surprised to hear that you read of problems with using Firefox on the PI 4.  I would have thought Chrome would perhaps bog the Pi 4, down.   You could try the Opera browser (get the full Opera browser, not the mini Opera)
Title: Re: Slowwww web browsing on RPi 4
Post by: gmiller1977 on January 09, 2021, 10:29:19 am
Are you using Wifi or the NIC?
Title: Re: Slowwww web browsing on RPi 4
Post by: fox on January 09, 2021, 12:02:33 pm
Wifi
Title: Re: Slowwww web browsing on RPi 4
Post by: gmiller1977 on January 09, 2021, 01:12:54 pm
If you try using the NIC is there any change in performance? 
Title: Re: Slowwww web browsing on RPi 4
Post by: fox on January 09, 2021, 04:09:06 pm
I'm on the Pi now and posting from Chromium. Turned out that the update I thought I did was not complete, and the version of Chromium I was running was very old. I am now running Chromium 86, and the performance is much better. No more typing delays, and tabs close with only a minor  delay. And I'm still using the Noobs SD card. Next step will be to set up BerryBoot and then try installing NextCloud. (Been awhile since your presentation, Jason. I hope I can follow it.)

Thanks guys; another instance of why I'm glad to support our forums!
Title: Re: Slowwww web browsing on RPi 4
Post by: Jason on January 10, 2021, 04:27:27 pm
Sounds to me like some hardware is not working correctly.  I would suspect the SD card.
I am surprised to hear that you read of problems with using Firefox on the PI 4.  I would have thought Chrome would perhaps bog the Pi 4, down.   You could try the Opera browser (get the full Opera browser, not the mini Opera)

Firefox on the Pi last time I used it was as slow as molasses. RPi uses Chromium, not Chrome. Chrome is based on Chromium code but they're separate browsers. Chromium is Open Source. I don't know why Firefox is so slow. I suspect they just haven't optimized it to run on ARM very well whereas Google has because of their experience with Android. Opera isn't available for the RPi, at least not the last time I checked. And because it's not Open Source, nobody else can make a version for it.

Glad you got it working, Fox!
Title: Re: Slowwww web browsing on RPi 4
Post by: fox on January 10, 2021, 05:31:04 pm
I'm posting this from Firefox on my Pi4. I think I have the 64 bit Raspberry Pi OS installed on BerryBoot. I updates the software and installed Firefox; this is the ESR version. It seems to be running fine; as good as Chromium.
Title: Re: Slowwww web browsing on RPi 4
Post by: Jason on January 10, 2021, 06:26:50 pm
I'm posting this from Firefox on my Pi4. I think I have the 64 bit Raspberry Pi OS installed on BerryBoot. I updates the software and installed Firefox; this is the ESR version. It seems to be running fine; as good as Chromium.

Have you tried scrolling long webpages? That's where I found Firefox lagged as well as some screen updating issues. It could be because of a better graphics chip or that Firefox uses more RAM (on the Pi) so the additional memory helps.
Title: Re: Slowwww web browsing on RPi 4
Post by: fox on January 10, 2021, 09:25:43 pm
Scrolling web pages seems OK, but I didn't try any really long ones. However, I did notice that Firefox takes longer than Chromium to boot up to the default web page.
Title: Re: Slowwww web browsing on RPi 4
Post by: ssfc72 on January 11, 2021, 02:57:40 am
Very good. Looks like you solved your PI issue, yourself, without our possible solutions. :-)

I'm on the Pi now and posting from Chromium. Turned out that the update I thought I did was not complete, and the version of Chromium I was running was very old. I am now running Chromium 86, and the performance is much better. No more typing delays, and tabs close with only a minor  delay. And I'm still using the Noobs SD card. Next step will be to set up BerryBoot and then try installing NextCloud. (Been awhile since your presentation, Jason. I hope I can follow it.)

Thanks guys; another instance of why I'm glad to support our forums!