Linux & Android > Linux Applications & Android apps

Running Netflix on LibreElec/Kodi

(1/1)

fox:
DistroWatch did a review of LibreElec/Kodi this week ((here). Jesse looked first at LibreElec on an RPi and wasn't even able to run it. Then he looked at Kodi as an app, and was unable to run Netflix on it. I had no problems installing and running LibreElec on my original Pi 3B and my Pi 4. Playing local content worked, as did some of the channels available on Kodi, but I hadn't tried running Netflix, or any streaming service like that, on Kodi. Have any of you tried this, and does it work?

ssfc72:
I don't have the Netflix $ervice, so I haven't tried to run it under Kodi.

gmiller1977:
I thought Netflix has some type of DRM for it's content, and unless you are running on x86 you need to jump through some hoops to get it to work.

I'm quite pleased with running Netflix/PLEX on my Roku 3.

Jason:
I find it very doubtful that you can't run LibreELEC on it. It's one of the images that you can install from NOOBS but I haven't tried it recently. I believe I did install it successfully on the Pi once but I don't think I did anything with it. I didn't really know much about Kodi - still don't really.

I tried setting up Netflix on Raspbian OS and couldn't get it to work. They do use DRM, Widevine I believe, and the article I tried referred to a repository that no longer existed, the same issue that Jessie mentioned. It works fine on my PC in Linux (in Brave and did in Firefox and Chrome last I checked) and I don't even need to do anything special.

Navigation

[0] Message Index

Go to full version