Linux & Android > Raspberry Pi & Single-Board Computers

A warning on use of BerryBoot for your RPi

(1/2) > >>

I've been a big fan of BerryBoot because it lets one easily set up multiple distros on a Raspberry Pi. But I learned one bad thing about it today. Once you set it up with wifi and without plugging in your ethernet cable, you cannot use it with ethernet unless you start all over. I had BerryBoot set up to use four OSes, including NextCloud and OpenMediaVault. When I went to try out either, I couldn't get them off of the command line and I couldn't even get them on wifi. I figured that plugging them into my ethernet would give me an internet connection, but they wouldn't connect. I went back to Raspberry Pi OS, plugged in the cable and turned off wifi, and it wouldn't connect either. I tried modifying the config file to allow a cable connection, but I couldn't make that work either. I tried searching for an answer, and one post indicated that if you don't set it up initially with ethernet plugged in, the only way you can get an ethernet connection is to reset it, which means losing whatever OSes you have set up. Not a big deal since I'm only playing with it, but now I know.

I think that this is specific to BerryBoot because when I put in the Noobs card SD that came with my kit and ran the Raspberry Pi that I had previously set up, it could connect by ethernet. Now that I know, I want to reset BerryBoot with the ethernet plugged in before trying OpenMediaVault. I had a spare SD card and I successfully set up OMV by putting Raspberry Pi OS light on the card with the cable plugged in, but not in BerryBoot. An advantage to setting it up in BerryBoot, in addition to being able to use multiple OSes, is that BB makes it easy to set up your distro(s) to boot from a USB drive.

Thanks for the tip, Mike. Very good info, to know.

It's Linux so I would expect there to be a way via the terminal to switch to ethernet networking. However, on the RPi 3, not sure if it's the case for the RPi 4, ethernet is shared with USB. So it may be that the Pi has to load a special driver related to USB that isn't installed unless you choose a hard-wired connection on install. If you go the other way, it might work, start with wired and then switch to wireless. If so, that's possibly the issue.

I'm not sure if the USB-Ethernet setup is different in the Pi 3 and the Pi 4, but the connection setup is definitely different between BerryBoot and a single distro startup manager like the one you get in Noobs or by installing Raspberry Pi OS directly on your SD card. I know that because I tried both from wifi, and BerryBoot will not run through a wired connection after that, whereas the single distro installations will. But any of those systems will work on wifi if you install them with Ethernet first.

You're probably right that there must be some way to switch a BerryBoot wifi installation to an Ethernet network, but I couldn't find instructions on how to do this. I did try modifying the config file in BerryBoot to allow an Ethernet connection, but I couldn't make it work. In the end, it was easier to just start over again, this time with the Ethernet connection, than to try to fix what I had previously. That's the nice thing about having a Pi, at least for me. I'm using it to try things and to learn, not to depend on it for any particular use. If I ever get to the point where I actually want to use it for something, I'll probably buy a second Pi for more experimentation.

I'm not sure if I quite understand here. Did Berryboot setup your connection or the installer?


[0] Message Index

[#] Next page

Go to full version